Ubuntu [Bug 154697]

El mismo día que instalé Ubuntu me topé con la mala noticia que mientras actualizaba el sistema de 7.10 a 8.04 me salieron un par de errores relacionados al package update-manager y a algunas dependencias que por ahí siempre se nos van o bueno al desarrollador del SO se le va… Ya sabía que éste bug tenía una solución y era automática, nisiquiera necesitaba reiniciar mis X’s.. incluso sabía que éste bug era un poco antiguo. Fue reportado por Laurent Malvert el 2007-10-solver V20.. es decir mientras él actualizaba de 7.04 a 7.10… Hay muchas personas que pues la solución no fue automática y tuvieron que solucionar algunos temas de dependencias..

Éste es el bug:

package update-manager 1:0.81 failed to install/upgrade: ErrorMessage: SystemError in cache.commit(): E:Sub-process /tmp/tmpjP6Bsx/backports/usr/bin/dpkg returned an error code (1), E:Sub-process /tmp/tmpjP6Bsx/backports/usr/bin/dpkg returned an error code (1), E:Sub-process /tmp/tmpjP6Bsx/backports/usr/bin/dpkg returned an error code (1), E:Sub-process /tmp/tmpjP6Bsx/backports/usr/bin/dpkg returned an error code (1)

En la web hay bastantes soluciones y comentarios al respecto… Yo lo solucioné de manera automática, sin embargo hace un unos días cuando quise actualizar el sistema me salió un pequeño error, recibí algunos correos luego de reportar..:

Kattollikisd 26-04-08
Yea >:-(   i see... the same is happening to me now!

TeliuTe 29-04-08
the same when i update from 7.10 to 8.04 lts

** Attachment added: "none.gif"
   http://launchpadlibrarian.net/14004804/none.gif

wycito 29-04-08
What I did was to completely reinstall system which was a pain in the arse
to reconfigure grub and fstab but well, I have done worse things

** Attachment added: "unnamed"
   http://launchpadlibrarian.net/14010298/unnamed

Obviamente la última respuesta estuvo un poco tirada de los pelos… lo único que hice y por simple que parezca fue darle un sudo aptitude update… actualicé todos los paquetes y pues aparecieron algunos rotos.. reinicié mi X’s y nada.. todo normal… Las locuras de Ubuntu pensé, pero bueno ahora está todo bien =)!

Anuncios

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s